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This document details support provided by the current release of Autodesk Navisworks 2017
solutions (including Autodesk Navisworks Simulate and Autodesk Navisworks Manage) for:

o CAD file formats.

e Laser scan formats.

o CAD applications.

e Scheduling software.

NOTE: When referring to Navisworks or Autodesk Navisworks 2017 solutions in this document this
does NOT include Autodesk Navisworks Freedom 2017, which only reads NWD or DWF files.
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Supported CAD File Formats

Navisworks has its own native file formats (.nwd, .nwf, .nwc); however Autodesk Navisworks
solutions can additionally read a combination of many popular 3D CAD formats. The following table
lists the CAD file formats currently supported by Autodesk Navisworks 2017 solutions.

Note: Unless stated below backward compatibility for previous versions cannot always be
guaranteed.

Format Extension File Format Version
Navisworks .nwd .nwf .nwc All versions

AutoCAD .dwg, .dxf Up to AutoCAD 2017
MicroStation (SE, J, V8 & XM) .dgn .prp .prw v7,v8

3D Studio .3ds .prj Up to Autodesk 3ds Max 2017
ACIS SAT .sat .sab All ASM SAT. Up to ACIS SAT v7

.model .session .exp .dlv3 RZSE
.CATPart .CATProduct .cgr

CIS/2 Stp STRUCTURAL_FRAME_SCHEMA

DWF/DWFx .dwf .dwfx All previous versions
FBX fbx FBX SDK 2017.0

IFC2X_PLATFORM, IFC2X_FINAL,

AfC IFC2X2_FINAL, IFC2X3, IFC4

igs .iges All versions

Supported CAD File Formats | 7
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Format Extension File Format Version

Inventor Ipt .iam .ipj Up to Inventor 2017

Informatix MicroGDS .man .cv7 v10

JT Open J Up to 10.0

NX . Upto 9.0

Legacy file format. Support up to

PDS Design Review 2007.

Parasolids X_b Up to schema 26

RVM . Up to 12.0 SP5

Revit . Up to 2017

SketchUp .Skp v5 up to 2016

Solidworks prt .sldprt .asm .sldasm  PAeJeRE=IFE210kES

STEP .Stp .step AP214, AP203E3, AP242

st Binary only

wrl .wrz VRML1, VRML2

pdf All versions

Pro/ENGINEER prt .asm .g .neu Wildfire 5.0, Creo Parametric 1.0-3.0
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Supported Exporters

The following table is a summary of 32 bit / 64 bit support for the Exporters included in Autodesk
Navisworks 2017.

Product \ Exporter Sﬁi)p?ci)trt Sﬁi);;trt

Autodesk AutoCAD 2017 No Yes

Autodesk 3ds Max 2017 No Yes

Autodesk 3ds Max Design 2010 - 2015

Autodesk Revit / Architecture / Structure / MEP 2017 No Yes

Microstation J Yes

Microstation 8 Yes

Microstion 8.9 Yes

Microstion V8i Yes

ArchiCAD- 15

ArchiCAD 16 Yes Yes
Yes
Yes
Yes

Supported Exporters | 10
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Supported Laser Scan Formats

The following table lists the laser scan formats currently supported by Autodesk Navisworks 2017
solutions.

Extension File Format Version
*.rcs *.rcp

.asc .txt n/a

fls .fws .iQscan .iQmod .iQwsp FARO SDK 5.5

.pts .ptx n/a

.3dd Version 3.5 or high

Native file NOT supported. Convert REIlEREVAS®IREEE all=
to ASCII laser file

.zfc .zfs SDK version 2.2.1.0

Supported Laser Scan Formats | 11
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Supported Scheduling Software

The following table contains a list of the project scheduling software and formats supported by
Autodesk Navisworks Simulate 2017 and Autodesk Navisworks Manage 2017.

Product

Powerproject
11 (11.x)
12 (12.0.03-042)

Requires Asta Powerproject to be installed on same
machine, to make link.

Project 2007 (SP1) to Requires Microsoft Project to be installed on same

Microsoft 2013 : machine, to make link.

Oracle Primavera

Engineering and

Construction Requires Primavera v6 , 7 or 8 Engineering and

6.2.1 (SP4 Hot Fix 1) Construction to be installed locally or remotely, along
7.0 (SP4) with the corresponding version of the Primavera SDK.
8.2 TimeLiner connects to the Primavera database via an
ODBC data source link.

Primavera P6 Web
Services

6.2.1 (SP1 Hot Fix 1)
7.0 (SP1 Hot Fix 1)

Requires Primavera P6 v6, 7 or 8 Web Services installed
within a suitable Web Application Server such as Oracle
Web Logic or JBoss on the same machine as your P6
database.

Does not require any project software to be installed.
This is the common project exchange format which can
be exported to from a number of scheduling packages.

Microsoft Project

Ml Exchange Format

Does not require any project software to be installed.
This is a common exchange format which can be
exported from a number of applications including,
CSV Exchange Format Microsoft Excel.

Navisworks Simulate and Manage can additionally export
TimeLiner task information to this format.

Supported Scheduling Software | 12
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Supported Applications

The following table is a non-exhaustive list of CAD applications and properties currently supported
by Autodesk Navisworks 2017 solutions, along with any additional information that may be
necessary to review your project files in Navisworks software.

Native Other

Exporter Format Format

Properties

Autodesk
AutoCAD 2017 v W v v
AutoCAD Details

Other Formats DWEF, DWFx, DXF, 3DS, FBX

o Navisworks reads the native AutoCAD .dwg file format.

o Navisworks supports AutoCAD Point Cloud.

o Models can be exported from AutoCAD software as .nwc format. Export to .nwc file format is
only supported from AutoCAD 2011 onwards.

e Object properties, (such as Material Colors and Entity Handles) are also supported by Navisworks
and these can be viewed in the ‘Properties’ window. To open the Properties window, go to
View tab > Workspace panel > Windows drop-down > Properties.

AutoCAD Architecture 2017 v Vv v v
AutoCAD Architecture Details

Ol e el i DWF, DWFX, DXF, 3DS, FBX

e Navisworks can read AutoCAD Architecture .dwyg files, without the necessity to install an Object
Enabler.

e Models can be exported from ADT/AutoCAD Architecture software as either .nwc or .nwd
format. Export to .nwc file format is only support from AutoCAD Architecture 2011 onwards.

o Navisworks supports AutoCAD Architecture object properties and these can be viewed in the
'Properties’ window. To open the Properties window, go to View tab > Workspace panel >
Windows drop-down > Properties. Automatic Properties are also supported for AutoCAD
Architecture.

e Autodesk Navisworks Simulate and Autodesk Navisworks Manage software support
ADT/AutoCAD Architecture textures.

Supported Applications | 13
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Native Other
Format Format

AutoCAD MEP 2017 Vv v v Ve
AutoCAD MEP Details

Ol EdZelinicl DWF, DWFx, DXF, 3DS, FBX

o Navisworks can read AutoCAD MEP.dwg files, without the necessity to install an Object Enabler.

e Models can be exported from Building Systems/AutoCAD MEP software as .nwc d format. Export
to .nwc file format is only support from AutoCAD MEP 2011 onwards.

o Navisworks supports Building Systems/AutoCAD MEP object properties and these can be viewed
in the 'Properties’ window. To open the Properties window, go to View tab> Workspace
panel > Windows drop-down > Properties.

e Autodesk Navisworks Simulate and Autodesk Navisworks Manage software support Building
Systems/AutoCAD MEP textures.

Exporter Properties

Autodesk Plant 3D 2017 e v v v
Autodesk Plant 3D Details

DWF, DWFx, DXF, 3DS

e Models can be exported from Plant 3D software as .nwc format. Export to .nwc file format is
only support from Autodesk Plant 3D 2011 onwards.

e In order to read an Autodesk Plant 3D.dwg file into Navisworks, you will need to install the
corresponding Object Enabler.

AutoCAD Civil 3D 2017 v v v v
Civil 3D Details

OiiplidZel i | DWF, DWFx, DXF, 3DS, FBX

o Navisworks supports AutoCAD Point Cloud.

e The Civil 3D native .dwg file can be read directly into Navisworks; however you will need to
install the corresponding Civil 3D Object Enabler (available to download from the Autodesk
website).

e Models can be exported from Civil 3D software as .nwc format. Export to .nwc file format is only
support from AutoCAD Civil 3D 2011 onwards.

o For Civil 3D 2017 object properties (such as Material Colors and Entity Handles) are also
supported by Navisworks and these can be viewed in the 'Properties’ window. To open the
Properties window, go to View tab> Workspace panel > Windows drop-down >
Properties.

Supported Applications | 14
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Native Other

Exporter Format Format

Properties

Autodesk CAD-Duct v v v v

CAD-Duct Details

Ol fHe ks | DWG, DXF, 3DS

e In order to read a CAD-Duct file into Navisworks, you either need CAD-Duct installed on the same
machine as Navisworks, or have the CAD-Duct Object Enabler installed. The CAD-Duct Object Enabler
can be downloaded from the CAD-Duct website, found under Support > Additional Files.

o |f CAD-Duct is installed, the Object Enabler is not necessary. Simply export to .nwc.
e In Navisworks, object properties can be viewed in the 'CAD-Duct' tab in the 'Properties window.
To open the Properties window, go to View > Control Bars > Properties.

Autodesk Inventor 5 to 11, 2009-2017 v v

Inventor Details

Ol dFedkEs | IGES, STEP, JT, FBX

o Navisworks supports Inventor properties and these can be viewed in the 'Properties’ window. To
open the Properties window, go to View tab > Workspace panel > Windows drop-down >
Properties.

o If you are using an Inventor Project file, (*.ipj) you will need to set this as the Active Project in
Navisworks, prior to opening your assembly drawings (*.iam). You can set the Active Project
either by opening your *.ipj file in Navisworks, or by going to Application Menu > Global
Options > File Readers > Inventor, then enter the full path and file name of your *.ipj file (e.g.
C:\my Inventor projects\project 1.ipj). Once loaded, you can then Open the corresponding
assemblies as usual.

Supported Applications | 15
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Native Other

Exporter Format Format

Properties

Revit 2017 v v v v
Revit Details

DWG, DWF, DWFx, DXF, DGN, FBX

e Navisworks can read Revit.rvt files

o Navisworks can export .nwc files directly from Revit software.
You will need to install Navisworks on the same machine as Revit.

o Revit properties are supported. These can be viewed in the 'Properties’ window. To open the
Properties window, go to View tab > Workspace panel > Windows drop-down >
Properties.

o Autodesk Navisworks Simulate and Autodesk Navisworks Manage software support the export
of textures and materials from Revit.

e For supported entities refer to the Navisworks Help documentation.

Revit Architecture 2017 v v v v
Revit Architecture Details

DWG, DWF, DWFx, DXF, DGN, FBX

e Navisworks can read Revit.rvt files

o Navisworks can export .nwc files directly from Revit Architecture software.
You will need to install Navisworks on the same machine as Revit Architecture.

e Revit properties are supported. These can be viewed in the 'Properties’ window. To open the
Properties window, go to View tab > Workspace panel > Windows drop-down >
Properties.

e Autodesk Navisworks Simulate and Autodesk Navisworks Manage software support the export
of textures and materials from Revit Architecture.

e For supported entities refer to the Navisworks Help documentation.

Revit Structure 2017 v v v v

Revit Structure Details

OliEEZelinicss DWG, DWF, DWFx, DXF, DGN, CIS/2, FBX

e Navisworks can read Revit.rvt files
o Navisworks can export .nwc files directly from Revit Structure software.
You will need to install Navisworks on the same machine as Revit Structure.

Supported Applications | 16
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e Revit properties are supported. These can be viewed in the ‘Properties’ window. To open the
Properties window, go to View tab > Workspace panel > Windows drop-down >
Properties.

Supported Applications | 17
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Native Other
Format Format

Revit MEP 2010-2017 v v v Ve
Revit MEP Details

Exporter Properties

OliEEZelineisy DWG, DWF, DWFX, DXF, DGN, FBX

o Navisworks can read Revit.rvt files

o Navisworks can export .nwec files directly from Revit Systems/Revit MEP software.
You will need to install Navisworks on the same machine as Revit Systems/Revit MEP.

e Revit properties are supported. These can be viewed in the 'Properties’ window. To open the
Properties window, go to View tab > Workspace panel > Windows drop-down >
Properties.

Autodesk 3ds Max 2017 Vv v
3ds Max Details

DWG, DXF, 3DS, IGES, FBX

e To view your 3ds Max model in Navisworks, you will need to have 3ds Max software installed on
the same machine and export to .nwc for use in Navisworks.

o Navisworks does not support .max files, so you cannot read the native file format directly into
Navisworks.

NOTE: Navisworks Simulate and Manage both support the export of textures and materials from 3ds
Max.

Autodesk Maya v
Maya Details

DXF, IGES, VRML

o Navisworks has file readers for .dxf, .igs .iges and .wrl .wrz.

Supported Applications | 18
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Bentley

Native Other
Format Format

AutoPLANT v Vv v v
AutoPlant Details

Exporter Properties

Other Formats DWG, DXF, 3DS

e In order to read an AutoPLANT DWG file into Navisworks, you will first need to install the
AutoPLANT Object Enabler.

NOTE: When using an object enabler, choose one of the same or later version as the authoring
application, and then ensure the corresponding (Navisworks) loader version (year) is selected in Tools >
Global Options > File Readers > DWG/DXF > DWG Loader Version.

e You can also export to .nwc if you have Navisworks installed on the same machine as
AUtOPLANT.

NOTE: To ensure geometry is rendered correctly when reading a DWG file into Navisworks, or exporting
from AutoPLANT, ensure the render type is set to Shaded in Tools > Global Options > File Readers >
DWG/DXF > Render Type.

MicroStation J v v v v
MicroStation J Details

DWG, DXF, DGN, IGES, STEP, VRML

e Models can be exported as NWC files from MicroStation J if you have Navisworks installed on
the same machine.

e Navisworks supports the native MicroStation .dgn file format, which can be read directly into
Navisworks.

o Object properties, such as colors and ambient, diffuse and shininess properties of materials from
.pal and .mat palette and material files are supported.

o Intergraph PDS object information can be read from .drv files and DMRS and database linkage
and association ID's are also supported. These can be viewed in the Properties window. To
open the Properties window, go to View tab > Workspace panel > Windows drop-down >
Properties.

e Autodesk Navisworks Simulate and Autodesk Navisworks Manage support MicroStation
materials and textures.

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within MicroStation
whenever possible.

NOTE: For exporting numerous files from MicroStation we recommend using the Perl script installed
with Navisworks (by default in, C:\Program Files\Autodesk\Navisworks [Review/Simulate/Manage]
2017\Tools).

Supported Applications | 19


http://www.navisworks.com/support/formats
http://www.navisworks.com/support/formats

Autodesk Navisworks 2017 Solutions

Native Other
Format Format

MicroStation v8 to 8.5, XM (8.9) v v v v

Exporter Properties

MicroStation Details

Other Formats DWG, DXF, DGN, IGES, STEP, VRML

e Models can be exported as NWC files from MicroStation V8 if you have Navisworks installed on
the same machine.

e Navisworks supports the native MicroStation V8 dgn file format, which can be read directly into
Navisworks.

o Object properties, such as colors and ambient, diffuse and shininess properties of materials from
.pal and .mat palette and material files are supported.

e Autodesk Navisworks Simulate and Autodesk Navisworks Manage support MicroStation
materials and textures.

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within MicroStation
whenever possible.

NOTE: For exporting numerous files from MicroStation we recommend using the Perl script installed
with Navisworks (by default in, C:\Program Files\Autodesk\Navisworks [Review/Simulate/Manage]
2017\Tools).

ProSteel 3D (formerly from Kiwi Software GmbH) v v v
ProSteel 3D Details

DWG, DXF, 3DS, CIS/2

e This information relates to ProSteel 3D / ProStahl 3D / AutoPLANT Structural.

o In order to read ProSteel files into Navisworks, you either need ProSteel 3D installed on the
same machine as Navisworks, or the relevant ProSteel 3D object enabler.

e Only basic AutoCAD properties are supported (such as Entity Handle and Material) and these
can be viewed in the Properties window. This can be opened by going to View tab>
Workspace panel > Windows drop-down > Properties.

Supported Applications | 20


http://www.navisworks.com/support/formats
http://www.navisworks.com/support/formats

Autodesk Navisworks 2017 Solutions

Native Other

Format Format Properties

Exporter

TriFormaJ v v v v

TriForma J Details

DWG, DXF, DGN, IGES, STEP, VRML

e Models can be exported as NWC files from Triforma J if you have Navisworks installed on the
same machine.

o Navisworks supports the native Triforma J .dgn file format, which can be read directly into
Navisworks.

o Obiject properties, such as colors and ambient, diffuse and shininess properties of materials from
.pal and .mat palette and material files are supported.

e Family and Part information from TriForma and PDS object information can be read from .drv
files and DMRS and database linkage and association ID's are also supported. These can be
viewed in the Properties window. To open the Properties window, go to View tab >
Workspace panel > Windows drop-down > Properties.

e Autodesk Navisworks Simulate and Autodesk Navisworks Manage support TriForma materials
and textures.

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within TriForma
whenever possible.

NOTE: For exporting numerous files from TriForma we recommend using the Perl script installed with
Navisworks (by default in, C:\Program Files\Autodesk\Navisworks [Simulate/Manage] 2017\Tools).
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Native Other
Format Format

TriForma v8 to 8.9 Vv Vv Vv

Exporter Properties

TriForma Details

Other Formats DWG, DXF, DGN, IGES, STEP, VRML

e Models can be exported as NWC files from TriForma V8 if you have Navisworks installed on the
same machine.

e Navisworks supports the native TriForma V8 dgn file format, which can be read directly into
Navisworks.

o Object properties, such as colors and ambient, diffuse and shininess properties of materials from
.pal and .mat palette and material files are supported.

e Autodesk Navisworks Simulate and Autodesk Navisworks Manage support TriForma materials
and textures.

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within TriForma
whenever possible.

NOTE: For exporting numerous files from TriForma we recommend using the Perl script installed with
Navisworks (by default in, C:\Program Files\Autodesk\Navisworks [Simulate/Manage] 2017\Tools).
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Graphisoft

Native Other
Format Format

ArchiCAD 16 to 19 v Vv v
ArchiCAD Details

Other Formats DWG, DXF, DGN, IFC

e ArchiCAD can export to Navisworks .nwc file format. Navisworks does NOT have a direct reader
for ArchiCAD files.

e ArchiCAD can also save files as .dwg, .dxf, .dgn and .ifc formats. These can be read directly by
Navisworks.

e Object properties, such as GUIDS and Library Part Parameters can optionally be exported with
the Navisworks file.

Exporter Properties

Constructor 2007 to 2010 v v v

Constructor Details

Other Formats DWG, DXF, DGN

e Constructor 2007 to 2010 can export to the Navisworks .nwc file format. Navisworks does NOT
have a direct reader for Constructor 2010 files.

e Object properties, such as GUIDS and Library Part Parameters can optionally be exported with
the Naviswaorks file.

AceCad
StruCad v
StruCad Details

Other Formats DXF, CIS/2

o StruCad files can be viewed in Navisworks, if they have been saved as .dxf or .stp format.
o Object properties are not supported.

auto.des.sys

form.z v
form.z Details

DWG, DXF, 3DS, IGES, STL, VRML

o Navisworks supports all of the above file formats, which form.z can export to.
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Adobe Systems Inc.

Native Other
Format Format
PDF v

PDF Details

o Navisworks supports Adobe Portable Document Format (PDF) files in the sheet browser, directly
from 2017.

e Only 2D pdf is supported, this does include multiple sheet files.

e For Navisworks 2015 users, the application may be found as a free download on the Autodesk
Navisworks Application Exchange.

Exporter Properties

AEC

CADPIPE Vs v v e
CADPIPE Details

e To view CADPIPE object properties in Navisworks, you may need to turn on the Convert Object
Properties option. To do this, go to Tools > Global Options > File Readers > DWG/DXF >
Advanced and select the CADPIPE option. Any CADPIPE properties can then be viewed in the
'Properties’ window. To open the Properties window, go to View tab> Workspace panel >
Windows drop-down > Properties.

e CADPIPE 'Industrial® and "Commercial' cannot be used at the same time. If both are installed,
then industrial is used. You can disable either or both by going to Tools > Global Options >
Registry > Current User > CADPIPE. Change the version you require to one (1) and disable
the other version by changing that value to zero (0).

AVEVA
PDMS v v
PDMS Details

Other Formats RVM

o Navisworks can read .rvm files exported from PDMS.

e AVEVA Review .rvs files are also supported. These require the same filename as the .rvm file.

e PDMS attribute files are supported, output using either the 'Dump Attributes’ or ‘Data’ formats.
These can be viewed in the 'Properties’ window. To open the Properties window, go to View
tab > Workspace panel > Windows drop-down > Properties.
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CADopia
Native Other
Format Format

IntelliCAD v v
IntelliCAD Details

Other Formats DWG, DXF

o Navisworks supports the native IntelliCAD .dwg file format, which can be read directly into
Navisworks.

Exporter Properties

CEA Technology

Native Other
Format Format

Plant-4D v
Plant-4D Details

o Navisworks has file readers for .dwg and .dgn files, both of which are supported by Plant-4D.

Exporter Properties

COADE, Inc.
Exporter Native Other Properties
P Format Format P
CADWorx Plant v v v v

CADWorx Plant Details

Other Formats DWG, DXF, 3DS

e Models can be exported from CADWorx as either .nwc or .nwd format, if you have Navisworks
installed on the same machine.

e Navisworks also provides support for .dwg files enabling native CADWorx models to be read
directly into Navisworks.

o CADWorx object properties are also supported by Navisworks and these can be viewed in the
'Properties’ window. To open the Properties window, go to View tab > Workspace panel >
Windows drop-down > Properties.

o CADWorx piping, steel, and equipment data is fully supported by Navisworks.
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Native Other

Format Format Properties

Exporter

CADWorx Pipe v v v v

CADWorx Pipe Detalls

e Models can be exported from CADWorx as either .nwc or .nwd format, if you have Navisworks
installed on the same machine.

o Navisworks also provides support for .dwg files enabling native CADWorx models to be read
directly into Navisworks.

o CADWorx object properties are also supported by Navisworks and these can be viewed in the
'Properties’ window. To open the Properties window, go to View tab > Workspace panel >
Windows drop-down > Properties.

o The legacy product, CADWorx Pipe, is fully supported by Navisworks.

CADWorx Steel v v v v

CADWorx Steel Details

Other Formats DWG, DXF, 3DS

e Models can be exported from CADWorx as either .nwc or .nwd format, if you have Navisworks
installed on the same machine.

o Navisworks also provides support for .dwg files enabling native CADWorx models to be read
directly into Navisworks.

o CADWorx object properties are also supported by Navisworks and these can be viewed in the
'Properties’ window. To open the Properties window, go to View tab > Workspace panel >
Windows drop-down > Properties.

o CADWorx Steel is fully supported by Navisworks.
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COINS

Native Other
Format Format

BSLink v v v v
BSLink Details

Other Formats DWG, DXF, 3DS

e In order to read a BSLink file into Navisworks, you either need BSLink installed on the same
machine as Navisworks, or AutoCAD installed complete with the BSLink object enabler.

o If BSLink is installed, the object enabler is not necessary. With Navisworks installed on the same
machine, simply export to .nwc or .nwd.

e In Navisworks, object properties can be viewed in the '‘BSLink" tab in the *Properties’ window.
To open the properties window, go to View tab > Workspace panel > Windows drop-
down > Properties.

Exporter Properties

Framing v v v v
Framing Details

Other Formats DWG, DXF, 3DS

e In order to read a Framing file into Navisworks, you either need COINS Framing installed on the
same machine as Navisworks, or ADT installed complete with the Framing object enabler.

o If COINS Framing is installed, the object enabler is not necessary. If Navisworks is installed on
the same machine, simply export to .nwc or .nwd.

e In Navisworks, object properties can be viewed in the Framing tab in the Properties window. To
open the properties window, go to View tab > Workspace panel > Windows drop-down >

Properties.
CSC
3D+ v s s
3D+ Details

e 3D+ has a Navisworks Exporter, enabling you to export a Navisworks file out of 3D+.

e Also see the 3D+ website for information on their 3D+ Navisworks Reader. This is a plug-in to
Naviswaorks, enabling you to read the native .3nwc file format in Navisworks.

o 3D+ object properties are supported by Navisworks via either of the above routes.
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Dassault Systemes

Native Other
Format Format

CATIA v
CATIA Details

Exporter Properties

Other Formats DXF, IGES, STEP, JT

e Navisworks has file readers for .dxf, .igs, .stp and .jt files, all of which can be exported from
CATIA.
e STEP is the preferred exchange format.

Google
SketchUp (up to 2016) v v
SketchUp Details

Other Formats DWG, 3DS

e SketchUp .skp files (v5 up to 2016 can be read directly into Navisworks.
e Grouping objects in SketchUp will make it easier to use the model in Navisworks, for example
applying materials, or attaching objects to TimeLiner tasks.

Hannappel SOFTWARE GmbH

elcoCAD R4 v v v v
elcoCAD R4 Details

e Models can be exported from elcoCAD as either .nwc or .nwd format.

o Navisworks also supports the native elcoCAD .dwg file format, which can be read directly into
Navisworks.

e Object properties are also supported by Navisworks and these can be viewed in the 'Properties’
window. To open the Properties window, go to View tab > Workspace panel > Windows
drop-down > Properties.
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Intergraph
Native Other .
Exporter Format  Format Properties
PDS v v v v
PDS Details

DWG, DXF, DGN, IGES, STEP

o Intergraph PDS will save the model geometry in a .dgn file and the property information in a
.drv file. Both files are required by Navisworks to read the model with object properties.

e In Navisworks, go to Tools > Global Options > DGN, scroll down and check the *Convert PDS
Data' option. Ensure the .dgn and .drv files reside in the same directory. Navisworks will then
import the model, along with its properties.

e PDS object properties can be viewed in the 'Properties’ window. To open the Properties
window, go to View tab > Workspace panel > Windows drop-down > Properties.

o If Navisworks has been installed onto the same machine as Intergraph PDS, you will be able to
export from PDS as a Navisworks .nwc or .nwd file.

Informatix
MicroGDS v
MicroGDS Details

Other Formats MAN

o Navisworks supports the native MicroGDS .man file format, which can be read directly into
Navisworks.

e Colors and Materials from the file are supported. The .man File Reader options can be found in
Tools > Global Options > File Readers > MAN.
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ITandFactory
Native Other .
Exporter Format  Format Properties
CADISON v v v v

CADISON Details

o Navisworks can directly read CADISON .dwg files, utilizing the .dwg file reader.

e In order to read a CADISON file into Navisworks, you either need CADISON installed on the
same machine as Navisworks, or you will need to install the CADISON Object Enabler.

o |f CADISON is installed, the object enabler is not necessary.

e With either CADISON or the Object Enabler installed, simply open the CADISON .dwg file in
Navisworks.

o |f CADISON is installed on the same machine as Navisworks, then you can also export to .nwc
or .nwd.

e Exporting a Navisworks file from CADISON also retains the models object properties that can be
viewed in the 'Properties’ window. To open the Properties window, go to View tab >
Workspace panel > Windows drop-down > Properties.

TRICAD MS v v v
TRICAD Details

Other Formats VRML

e If TriCAD MS is installed on the same machine as Navisworks, then you can also export to .nwc
or .nwd.

o Exporting a Navisworks file from TRICAD MS also retains the models object properties that can
be viewed in the 'Properties’ window. To open the Properties window, go to View tab >
Workspace panel > Windows drop-down > Properties.
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Kubotek USA

Native Other
Format Format

CADKEY v
CADKEY Details

Exporter Properties

Other Formats DWG, DXF, IGES, STEP

e Navisworks has file readers for .dwg files and also .dxf, .igs and .stp files, all of which are
supported by CADKEY.

M.A.P.

CAD-Duct v v v v
CAD-Duct Details

e In order to read a CAD-Duct file into Navisworks, you either need CAD-Duct installed on the
same machine as Navisworks, or have the CAD-Duct Object Enabler installed. The CAD-Duct
Object Enabler can be downloaded from the CAD-Duct website, found under Support >
Additional Files.

e |f CAD-Duct is installed, the Object Enabler is not necessary. Simply export to .nwd or .nwc.

e In Navisworks, object properties can be viewed in the "CAD-Duct’ tab in the 'Properties’
window. To open the Properties window, go to View tab > Workspace panel > Windows
drop-down > Properties.
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McNeel North America

Native Other
Format Format

Rhino v v
Rhino Details

Exporter Properties

Other Formats DWG, DXF, 3DS, IGES, STEP

e In Navisworks, you can now read native Rhino files directly.

Mensch und Maschine

RoCAD v v v v
RoCAD Detalils

e Models can be exported from RoCAD as either .nwc or .nwd.

o Navisworks also supports the .dwg file format, which can be read directly into Navisworks.

e If you do not have RoCAD installed on the same machine as Navisworks, you will need to have
AutoCAD installed, along with the RoCAD Object Enabler.

o Obiject properties, (such as Material Colors and Entity Handles) are also supported by
Navisworks and these can be viewed in the 'Properties’ window. To open the Properties
window, go to View tab > Workspace panel > Windows drop-down > Properties.

MultiSUITE
MultiSTEEL v v v

MultiSTEEL Details

e .dwyg files from MultiSTEEL can be read directly into Navisworks utilizing the .dwg file reader.

e Models can also be exported from MultiSTEEL as either .nwc or .nwd.

e MUuItiSTEEL object properties can be viewed in the 'Properties' window. To open the Properties
window, go to View tab > Workspace panel > Windows drop-down > Properties.
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Nemetschek
Native Other .
Exporter Format  Format Properties
Allplan v
Allplan Details

Ol aselinici DWG, DXF, DGN, IFC

e Allplan files can be viewed in Navisworks if they have been saved in one of the above formats.
e Object properties are not supported.

PROCAD
3DSMART v v
3DSMART Details

Other Formats DWG, DXF, 3DS

e With 3DSMART installed on the same machine as Navisworks, you can read your DWG file
directly into Navisworks, utilizing the DWG file reader.
e You can also export a .nwc file directly from 3DSMART.

PTC
Pro/ENGINEER v v
Pro/ENGINEER Details

Other Formats IGES, STEP, VRML, JT

o Native Pro/ENGINEER format support; .PRT .ASM .G .NEU
e Pro/ENGINEER models can be exported to any of the above file formats which can then be read
into Navisworks.

CADDS 5 v
CADDS 5 Details

Other Formats IGES, STEP

e You can read CADDS 5 3D models into Navisworks, by exporting either an IGES or STEP file
from CADDS 5 and then utilize either the Navisworks .igs, or .stp file readers.
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QuickPen

Native Other
Format Format

PipeDesigner 3D v v v v
PipeDesigner 3D Details

Other Formats DWG, DXF, 3DS

e Models can be exported from PipeDesigner 3D as either .nwc or .nwd format.

e Navisworks also supports the native .dwg file format, which can be read directly into
Navisworks if the relevant Object Enabler is installed.

o Object properties, (such as Material Colors and Entity Handles) are also supported by
Navisworks and these can be viewed in the 'Properties’ window. To open the Properties
window, go to View tab > Workspace panel > Windows drop-down > Properties.

Exporter Properties

DuctDesigner 3D v v Vs v
DuctDesigner 3D Details

Other Formats DWG, DXF, 3DS

e Models can be exported from DuctDesigner 3D as either .nwc or .nwd format.

e Navisworks also supports the native .dwg file format, which can be read directly into
Navisworks if the relevant Object Enabler is installed.

o Object properties, (such as Material Colors and Entity Handles) are also supported by
Navisworks and these can be viewed in the 'Properties’ window. To open the Properties
window, go to View tab > Workspace panel > Windows drop-down > Properties.

RAM International

CADstudio v v v v
CADstudio Details

Other Formats DWG, DXF, 3DS

e Models can be exported from CADstudio as either .nwc or .nwd format.

o Navisworks also supports the native CADstudio .dwg file format, which can be read directly into
Navisworks.

o Obiject properties are also supported by Navisworks and these can be viewed in the 'Properties’
window. To open the Properties window, go to View tab > Workspace panel > Windows
drop-down > Properties.
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SolidWorks
Native Other .
Exporter Format  Format Properties
SolidWorks v v

SolidWorks Details

Other Formats DWG, DXF, IGES, STEP, VRML, JT

e Native SolidWorks format support; .PRT .SLDPRT .ASM .SLDASM
e SolidWorks models can be exported to DWG, DXF, IGES, STEP, VRML or JT format which can
then be read into Navisworks.

Tekla
Tekla Structures v v

Tekla Structures Details

Other Formats DGN, VRML, CIS/2

e Tekla Structures can export to the .dgn file format, which can be read directly into Navisworks.

o Tekla Structures can additionally output to CIS/2. This may then be converted to VRML using
the translator from the National Institute of Standards and Technology (see the NIST website for
more information). The VRML file can then be read directly into Navisworks.

e Limited object properties are supported via the .dgn route.

Xsteel v v
Xsteel Details

Other Formats DGN

e Xsteel can export to the .dgn file format, which can be read directly into Navisworks.
e Limited object properties are supported via the .dgn route.

think3
thinkdesign v
thinkdesign Details

Other Formats DWG, DXF, IGES, STEP

e Navisworks has file readers for .dwg/.dxf files and also .igs and .stp files.
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UGS
Native Other .
Exporter Format  Format Properties
I-deas v
I-deas Details

Other Formats DXF, IGES, STEP, JT

e Navisworks has file readers for .dxf, .igs .stp and .jt files.

Solid Edge Ve
Solid Edge Details

Other Formats IGES, STEP, JT

e Solid Edge can export to IGES STEP and JT files, which can be read directly into Navisworks.

NX (Unigraphics) v v
NX Details

Other Formats DXF, IGES, STEP, JT

e Native NX format support; .PRT.
o Navisworks has file readers for .dxf, .igs .stp and .jt files.

FactoryCAD v v v
FactoryCAD Details

Other Formats DWG, DXF, 3DS

e In order to read a FactoryCAD file into Navisworks, you either need FactoryCAD or the
FactoryCAD object enabler installed on the same machine.
e If FactoryCAD is installed, the object enabler is not necessary. Simply export to .nwc or .nwd.
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UHP Process Piping

Native Other

Exporter Format Format

Properties

FabPro Pipe v v v
FabPro-Pipe Details

e Models can be exported from FabPro Pipe as either .nwc or .nwd format.
e Navisworks also supports the native FabPro Pipe .dwg file format, which can be read directly
into Navisworks.

x-plant
x-plant v v v
x-plant Details

Other Formats DWG, DXF, 3DS

e Models can be exported from x-plant as .nwc format.
o Navisworks also supports the native x-plant .dwg file format, which can be read directly into
Navisworks.
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