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Supported CAD File Formats 

Navisworks has its own native file formats (.nwd, .nwf, .nwc); however Autodesk Navisworks 

solutions can additionally read a combination of many popular 3D CAD formats. The following table 

lists the CAD file formats currently supported by Autodesk Navisworks 2017 solutions. 

 

Note: Unless stated below backward compatibility for previous versions cannot always be 

guaranteed. 

 

 

Format Extension File Format Version 

Navisworks .nwd .nwf .nwc All versions 

AutoCAD .dwg, .dxf Up to AutoCAD 2017 

MicroStation (SE, J, V8 & XM) .dgn .prp .prw v7, v8 

3D Studio .3ds .prj Up to Autodesk 3ds Max 2017 

ACIS SAT .sat .sab All ASM SAT. Up to ACIS SAT v7 

Catia 
.model .session .exp .dlv3 
.CATPart .CATProduct .cgr 

V4, v5 

CIS/2 .stp STRUCTURAL_FRAME_SCHEMA 

DWF/DWFx .dwf .dwfx All previous versions 

FBX .fbx FBX SDK  2017.0  

IFC .ifc 
IFC2X_PLATFORM, IFC2X_FINAL, 
IFC2X2_FINAL, IFC2X3, IFC4 

IGES .igs .iges All versions 
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Format Extension File Format Version 

Inventor .ipt .iam .ipj Up to Inventor 2017 

Informatix MicroGDS .man .cv7 v10 

JT Open .jt Up to 10.0 

NX .prt Up to 9.0 

PDS Design Review .dri 
Legacy file format. Support up to 
2007. 

Parasolids .x_b Up to schema 26 

Pro/ENGINEER .prt .asm .g .neu Wildfire 5.0, Creo Parametric 1.0-3.0 

RVM .rvm Up to 12.0 SP5 

Revit .rvt Up to 2017 

SketchUp .skp v5 up to 2016 

Solidworks .prt .sldprt .asm .sldasm 2001 Plus-2015 

STEP .stp .step AP214, AP203E3, AP242 

STL .stl Binary only 

VRML .wrl .wrz VRML1, VRML2 

PDF .pdf All versions 
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Rhino .3dm Up to 5.0 
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Supported Exporters 

The following table is a summary of 32 bit / 64 bit support for the Exporters included in Autodesk 

Navisworks 2017. 

 

 

Product \ Exporter 
32 bit 

Support 
64 bit 

Support 

Autodesk AutoCAD 2017 No Yes 

Autodesk 3ds Max 2017 No Yes 

Autodesk 3ds Max Design 2010  2015   

Autodesk Revit / Architecture / Structure / MEP 2017 No Yes 

Microstation J Yes  

Microstation 8 Yes  

Microstion 8.9 Yes  

Microstion V8i Yes  

ArchiCAD 15   

ArchiCAD 16 Yes Yes 

ArchiCAD 17  Yes 

ArchiCAD 18  Yes 

ArchiCAD 19  Yes 
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Supported Laser Scan Formats 

The following table lists the laser scan formats currently supported by Autodesk Navisworks 2017 

solutions. 

 

 

  

Format Extension File Format Version 

Autodesk ReCap *.rcs *.rcp  

ASCII Laser File .asc .txt n/a 

Faro .fls .fws .iQscan .iQmod .iQwsp FARO SDK 5.5 

Leica .pts .ptx n/a 

Riegl .3dd Version 3.5 or high 

Trimble 
Native file NOT supported. Convert 
to ASCII laser file 

Same as ASCII laser file 

Z+F .zfc .zfs SDK version 2.2.1.0 
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Supported Scheduling Software 

The following table contains a list of the project scheduling software and formats supported by 
Autodesk Navisworks Simulate 2017 and Autodesk Navisworks Manage 2017. 

Vendor Product 
File 
Format 

Notes 

Asta 
Powerproject 
11 (11.x) 
12 (12.0.03-042) 

.pp 
Requires Asta Powerproject to be installed on same 
machine, to make link. 

Microsoft 
Project 2007 (SP1)  to 
2013 

.mpp 
Requires Microsoft Project to be installed on same 
machine, to make link. 

    

Oracle 

Oracle Primavera 
Engineering and 
Construction 
6.2.1 (SP4 Hot Fix 1) 
7.0 (SP4) 
8.2 

 

n/a 

Requires Primavera v6 , 7 or 8 Engineering and 
Construction to be installed locally or remotely, along 
with the corresponding version of the Primavera SDK. 
TimeLiner connects to the Primavera database via an 
ODBC data source link. 

Oracle 

Primavera P6 Web 
Services 
6.2.1 (SP1 Hot Fix 1) 
7.0 (SP1 Hot Fix 1) 
8.2 
8.3 
 

n/a 

Requires Primavera P6 v6, 7 or 8 Web Services installed 
within a suitable Web Application Server such as Oracle 
Web Logic or JBoss on the same machine as your P6 
database. 

Microsoft 
Microsoft Project 
Exchange Format 

.mpx 
Does not require any project software to be installed. 
This is the common project exchange format which can 
be exported to from a number of scheduling packages. 

N/A CSV Exchange Format .csv 

Does not require any project software to be installed. 
This is a common exchange format which can be 
exported from a number of applications including, 
Microsoft Excel. 

Navisworks Simulate and Manage can additionally export 
TimeLiner task information to this format. 
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Supported Applications 

The following table is a non-exhaustive list of CAD applications and properties currently supported 

by Autodesk Navisworks 2017 solutions, along with any additional information that may be 

necessary to review your project files in Navisworks software. 

 

  Exporter 
Native 
Format 

Other 
Format 

Properties 

Autodesk  

AutoCAD 2017 
    

AutoCAD Details  

Other Formats DWF, DWFx, DXF, 3DS, FBX 

 Navisworks reads the native AutoCAD .dwg file format.  
 Navisworks supports AutoCAD Point Cloud. 
 Models can be exported from AutoCAD software as  .nwc format. Export to .nwc file format is 

only supported from AutoCAD 2011 onwards. 
 Object properties, (such as Material Colors and Entity Handles) are also supported by Navisworks 

and these can be viewed in the 'Properties' window. To open the Properties window, go to 
View tab > Workspace panel > Windows drop-down > Properties.  

AutoCAD Architecture 2017 
    

AutoCAD Architecture Details  

Other Formats DWF, DWFx, DXF, 3DS, FBX 

 Navisworks can read AutoCAD Architecture .dwg files, without the necessity to install an Object 
Enabler. 

 Models can be exported from ADT/AutoCAD Architecture software as either .nwc or .nwd 
format. Export to .nwc file format is only support from AutoCAD Architecture 2011 onwards. 

 Navisworks supports AutoCAD Architecture object properties and these can be viewed in the 
'Properties' window. To open the Properties window, go to View tab > Workspace panel > 
Windows drop-down > Properties. Automatic Properties are also supported for AutoCAD 
Architecture.  

 Autodesk Navisworks Simulate and Autodesk Navisworks Manage software support 
ADT/AutoCAD Architecture textures. 

  

http://www.navisworks.com/support/formats
http://www.navisworks.com/support/formats
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  Exporter 
Native 
Format 

Other 
Format 

Properties 

AutoCAD MEP 2017 
    

AutoCAD MEP Details  

Other Formats DWF, DWFx, DXF, 3DS, FBX 

 Navisworks can read AutoCAD MEP.dwg files, without the necessity to install an Object Enabler. 
 Models can be exported from Building Systems/AutoCAD MEP software as .nwc d format. Export 

to .nwc file format is only support from AutoCAD MEP 2011 onwards. 
 Navisworks supports Building Systems/AutoCAD MEP object properties and these can be viewed 

in the 'Properties' window. To open the Properties window, go to View tab> Workspace 
panel > Windows drop-down > Properties.  

 Autodesk Navisworks Simulate and Autodesk Navisworks Manage software support Building 
Systems/AutoCAD MEP textures. 

Autodesk Plant 3D 2017 
    

Autodesk Plant 3D Details  

Other Formats DWF, DWFx, DXF, 3DS 

 Models can be exported from Plant 3D software as .nwc format. Export to .nwc file format is 
only support from Autodesk Plant 3D 2011 onwards. 

 In order to read an Autodesk Plant 3D.dwg file into Navisworks, you will need to install the 
corresponding Object Enabler.  

AutoCAD Civil 3D 2017 
 

  
  

Civil 3D Details  

Other Formats DWF, DWFx, DXF, 3DS, FBX 

 Navisworks supports AutoCAD Point Cloud. 
 The Civil 3D native .dwg file can be read directly into Navisworks; however you will need to 

install the corresponding Civil 3D Object Enabler (available to download from the Autodesk 
website). 

 Models can be exported from Civil 3D software as .nwc format. Export to .nwc file format is only 
support from AutoCAD Civil 3D 2011 onwards. 

 For Civil 3D 2017 object properties (such as Material Colors and Entity Handles) are also 
supported by Navisworks and these can be viewed in the 'Properties' window. To open the 
Properties window, go to View tab> Workspace panel > Windows drop-down > 
Properties. 

 

http://www.navisworks.com/support/formats
http://www.navisworks.com/support/formats
http://www.navisworks.com/support/formats
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  Exporter 
Native 
Format 

Other 
Format 

Properties 

 

Autodesk CAD-Duct     

CAD-Duct Details 

Other Formats DWG, DXF, 3DS 

 
 In order to read a CAD-Duct file into Navisworks, you either need CAD-Duct installed on the same 

machine as Navisworks, or have the CAD-Duct Object Enabler installed. The CAD-Duct Object Enabler 
can be downloaded from the CAD-Duct website, found under Support > Additional Files. 

 

 If CAD-Duct is installed, the Object Enabler is not necessary. Simply export to .nwc. 
 In Navisworks, object properties can be viewed in the 'CAD-Duct' tab in the 'Properties window. 

To open the Properties window, go to View > Control Bars > Properties. 

Autodesk Inventor 5 to 11, 2009-2017   
  

  

Inventor Details  

Other Formats IGES, STEP, JT, FBX 

 Navisworks  supports Inventor properties and these can be viewed in the 'Properties' window. To 
open the Properties window, go to View tab > Workspace panel > Windows drop-down > 
Properties. 

 If you are using an Inventor Project file, (*.ipj) you will need to set this as the Active Project in 
Navisworks, prior to opening your assembly drawings (*.iam). You can set the Active Project 
either by opening your *.ipj file in Navisworks, or by going to Application Menu > Global 
Options > File Readers > Inventor, then enter the full path and file name of your *.ipj file (e.g. 
C:\my Inventor projects\project 1.ipj). Once loaded, you can then Open the corresponding 
assemblies as usual. 

  

http://www.navisworks.com/support/formats
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  Exporter 
Native 
Format 

Other 
Format 

Properties 

  

Revit 2017 
    

Revit Details  

Other Formats DWG, DWF, DWFx, DXF, DGN, FBX 

 Navisworks can read Revit.rvt files 
 Navisworks can export .nwc files directly from Revit software. 

You will need to install Navisworks on the same machine as Revit.  
 Revit properties are supported. These can be viewed in the 'Properties' window. To open the 

Properties window, go to View tab > Workspace panel > Windows drop-down > 
Properties.  

 Autodesk Navisworks Simulate and Autodesk Navisworks Manage software support the export 
of textures and materials from Revit. 

 For supported entities refer to the Navisworks Help documentation. 

Revit Architecture 2017 
    

Revit Architecture Details  

Other Formats DWG, DWF, DWFx, DXF, DGN, FBX 

 Navisworks can read Revit.rvt files 
 Navisworks can export .nwc files directly from Revit Architecture software. 

You will need to install Navisworks on the same machine as Revit Architecture.  
 Revit properties are supported. These can be viewed in the 'Properties' window. To open the 

Properties window, go to View tab > Workspace panel > Windows drop-down > 
Properties.  

 Autodesk Navisworks Simulate and Autodesk Navisworks Manage software support the export 
of textures and materials from Revit Architecture. 

 For supported entities refer to the Navisworks Help documentation. 

Revit Structure 2017 
    

Revit Structure Details  

Other Formats DWG, DWF, DWFx, DXF, DGN, CIS/2, FBX 

 Navisworks can read Revit.rvt files 
 Navisworks can export .nwc files directly from Revit Structure software. 

You will need to install Navisworks on the same machine as Revit Structure.  

http://www.navisworks.com/support/formats
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 Revit properties are supported. These can be viewed in the 'Properties' window. To open the 
Properties window, go to View tab > Workspace panel > Windows drop-down > 
Properties.  
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  Exporter 
Native 
Format 

Other 
Format 

Properties 

Revit MEP 2010-2017 
    

Revit MEP Details  

Other Formats DWG, DWF, DWFx, DXF, DGN, FBX 

 Navisworks can read Revit.rvt files 
 Navisworks can export .nwc files directly from Revit Systems/Revit MEP software. 

You will need to install Navisworks on the same machine as Revit Systems/Revit MEP.  
 Revit properties are supported. These can be viewed in the 'Properties' window. To open the 

Properties window, go to View tab > Workspace panel > Windows drop-down > 
Properties.  

Autodesk 3ds Max 2017 
 

 
 

 

3ds Max Details  

Other Formats DWG, DXF, 3DS, IGES, FBX 

 To view your 3ds Max model in Navisworks, you will need to have 3ds Max software installed on 
the same machine and export to .nwc for use in Navisworks.  

 Navisworks does not support .max files, so you cannot read the native file format directly into 
Navisworks. 

NOTE: Navisworks Simulate and Manage both support the export of textures and materials from 3ds 
Max.  

 

Autodesk Maya   
 

 

Maya Details  

Other Formats DXF, IGES, VRML 

 Navisworks has file readers for .dxf, .igs .iges and .wrl .wrz.   

http://www.navisworks.com/support/formats
http://www.navisworks.com/support/formats
http://www.navisworks.com/support/formats
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Bentley  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

AutoPLANT 
    

AutoPlant Details  

Other Formats DWG, DXF, 3DS 

 In order to read an AutoPLANT DWG file into Navisworks, you will first need to install the 
AutoPLANT Object Enabler.  

NOTE: When using an object enabler, choose one of the same or later version as the authoring 
application, and then ensure the corresponding (Navisworks) loader version (year) is selected in Tools > 
Global Options > File Readers > DWG/DXF > DWG Loader Version. 

 You can also export to .nwc if you have Navisworks installed on the same machine as 
AutoPLANT. 

NOTE: To ensure geometry is rendered correctly when reading a DWG file into Navisworks, or exporting 
from AutoPLANT, ensure the render type is set to Shaded in Tools > Global Options > File Readers > 
DWG/DXF > Render Type. 

MicroStation J 
    

MicroStation J Details  

Other Formats DWG, DXF, DGN, IGES, STEP, VRML 

 Models can be exported as NWC files from MicroStation J if you have Navisworks installed on 
the same machine.  

 Navisworks supports the native MicroStation .dgn file format, which can be read directly into 
Navisworks.  

 Object properties, such as colors and ambient, diffuse and shininess properties of materials from 
.pal and .mat palette and material files are supported.  

 Intergraph PDS object information can be read from .drv files and DMRS and database linkage 
and association ID's are also supported. These can be viewed in the Properties window. To 
open the Properties window, go to View tab > Workspace panel > Windows drop-down > 
Properties.  

 Autodesk Navisworks Simulate and Autodesk Navisworks Manage support MicroStation 
materials and textures. 

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within MicroStation 
whenever possible.  

NOTE: For exporting numerous files from MicroStation we recommend using the Perl script installed 
with Navisworks (by default in, C:\Program Files\Autodesk\Navisworks [Review/Simulate/Manage] 
2017\Tools).  

http://www.navisworks.com/support/formats
http://www.navisworks.com/support/formats
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  Exporter 
Native 
Format 

Other 
Format 

Properties 

MicroStation v8 to 8.5, XM (8.9) 
    

MicroStation Details  

Other Formats DWG, DXF, DGN, IGES, STEP, VRML 

 Models can be exported as NWC files from MicroStation V8 if you have Navisworks installed on 
the same machine.   

 Navisworks supports the native MicroStation V8 dgn file format, which can be read directly into 
Navisworks. 

 Object properties, such as colors and ambient, diffuse and shininess properties of materials from 
.pal and .mat palette and material files are supported. 

 Autodesk Navisworks Simulate and Autodesk Navisworks Manage support MicroStation 
materials and textures. 

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within MicroStation 
whenever possible.  
 
NOTE: For exporting numerous files from MicroStation we recommend using the Perl script installed 
with Navisworks (by default in, C:\Program Files\Autodesk\Navisworks [Review/Simulate/Manage] 
2017\Tools).  

 

ProSteel 3D (formerly from Kiwi Software GmbH) 
   

 

ProSteel 3D Details  

Other Formats DWG, DXF, 3DS, CIS/2 

 This information relates to ProSteel 3D / ProStahl 3D / AutoPLANT Structural.  
 In order to read ProSteel files into Navisworks, you either need ProSteel 3D installed on the 

same machine as Navisworks, or the relevant ProSteel 3D object enabler.  
 Only basic AutoCAD properties are supported (such as Entity Handle and Material) and these 

can be viewed in the Properties window. This can be opened by going to View tab> 
Workspace panel > Windows drop-down > Properties.  

  

http://www.navisworks.com/support/formats
http://www.navisworks.com/support/formats
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  Exporter 
Native 
Format 

Other 
Format 

Properties 

 

TriForma J     

TriForma J Details  

Other Formats DWG, DXF, DGN, IGES, STEP, VRML 

 Models can be exported as NWC files from Triforma J if you have Navisworks installed on the 
same machine. 

 Navisworks supports the native Triforma J .dgn file format, which can be read directly into 
Navisworks.  

 Object properties, such as colors and ambient, diffuse and shininess properties of materials from 
.pal and .mat palette and material files are supported.  

 Family and Part information from TriForma and PDS object information can be read from .drv 
files and DMRS and database linkage and association ID's are also supported. These can be 
viewed in the Properties window. To open the Properties window, go to View tab > 
Workspace panel > Windows drop-down > Properties.  

 Autodesk Navisworks Simulate and Autodesk Navisworks Manage support TriForma materials 
and textures.  

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within TriForma 
whenever possible.  

 

NOTE: For exporting numerous files from TriForma we recommend using the Perl script installed with 
Navisworks (by default in, C:\Program Files\Autodesk\Navisworks [Simulate/Manage] 2017\Tools).  

 

  

http://www.navisworks.com/support/formats
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  Exporter 
Native 
Format 

Other 
Format 

Properties 

TriForma v8 to 8.9 
 

 
  

TriForma Details  

Other Formats DWG, DXF, DGN, IGES, STEP, VRML 

 Models can be exported as NWC files from TriForma V8 if you have Navisworks installed on the 
same machine.   

 Navisworks supports the native TriForma V8 dgn file format, which can be read directly into 
Navisworks. 

 Object properties, such as colors and ambient, diffuse and shininess properties of materials from 
.pal and .mat palette and material files are supported. 

 Autodesk Navisworks Simulate and Autodesk Navisworks Manage support TriForma materials 
and textures. 

NOTE: For optimum file fidelity we recommend the NWC (or NWD) Exporter from within TriForma 

whenever possible.  

NOTE: For exporting numerous files from TriForma we recommend using the Perl script installed with 

Navisworks (by default in, C:\Program Files\Autodesk\Navisworks [Simulate/Manage] 2017\Tools). 

  

http://www.navisworks.com/support/formats
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Graphisoft  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

ArchiCAD 16 to 19 
 

 
  

ArchiCAD Details  

Other Formats DWG, DXF, DGN, IFC 

 ArchiCAD can export to Navisworks .nwc file format. Navisworks does NOT have a direct reader 
for ArchiCAD files.  

 ArchiCAD can also save files as .dwg, .dxf, .dgn and .ifc formats. These can be read directly by 
Navisworks.  

 Object properties, such as GUIDS and Library Part Parameters can optionally be exported with 
the Navisworks file.  

Constructor 2007 to 2010 
 

 
  

Constructor Details  

Other Formats DWG, DXF, DGN 

 Constructor 2007 to 2010 can export to the Navisworks .nwc file format. Navisworks does NOT 
have a direct reader for Constructor 2010 files.  

 Object properties, such as GUIDS and Library Part Parameters can optionally be exported with 
the Navisworks file.  

AceCad  

StruCad   
 

 

StruCad Details  

Other Formats DXF, CIS/2 

 StruCad files can be viewed in Navisworks, if they have been saved as .dxf or .stp format.  
 Object properties are not supported. 

auto.des.sys  

form.z   
 

 

form.z Details  

Other Formats DWG, DXF, 3DS, IGES, STL, VRML 

 Navisworks supports all of the above file formats, which form.z can export to.  
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Adobe Systems Inc. 

  Exporter 
Native 
Format 

Other 
Format 

Properties 

PDF  
 

  

PDF Details  

Other Formats PDF 

 Navisworks supports Adobe Portable Document Format (PDF) files in the sheet browser, directly 
from 2017. 

 Only 2D pdf is supported, this does include multiple sheet files. 
 For Navisworks 2015 users, the application may be found as a free download on the Autodesk 

Navisworks Application Exchange. 

AEC  

CADPIPE 
    

CADPIPE Details  

Other Formats DWG, DXF, 3DS 

 To view CADPIPE object properties in Navisworks, you may need to turn on the Convert Object 
Properties option. To do this, go to Tools > Global Options > File Readers > DWG/DXF > 
Advanced and select the CADPIPE option. Any CADPIPE properties can then be viewed in the 
'Properties' window. To open the Properties window, go to View tab> Workspace panel > 
Windows drop-down > Properties.  

 CADPIPE 'Industrial' and 'Commercial' cannot be used at the same time. If both are installed, 
then industrial is used. You can disable either or both by going to Tools > Global Options > 
Registry > Current User > CADPIPE. Change the version you require to one (1) and disable 
the other version by changing that value to zero (0). 

AVEVA  

PDMS   
  

PDMS Details  

Other Formats RVM 

 Navisworks can read .rvm files exported from PDMS.  

 AVEVA Review .rvs files are also supported. These require the same filename as the .rvm file.  

 PDMS attribute files are supported, output using either the 'Dump Attributes' or 'Data' formats. 
These can be viewed in the 'Properties' window. To open the Properties window, go to View 
tab > Workspace panel > Windows drop-down > Properties.  
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CADopia  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

IntelliCAD  
  

 

IntelliCAD Details  

Other Formats DWG, DXF 

 Navisworks supports the native IntelliCAD .dwg file format, which can be read directly into 
Navisworks.  

CEA Technology  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

Plant-4D   
 

 

Plant-4D Details  

Other Formats DWG, DGN 

 Navisworks has file readers for .dwg and .dgn files, both of which are supported by Plant-4D.  

COADE, Inc.  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

CADWorx Plant 
    

CADWorx Plant Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from CADWorx as either .nwc or .nwd format, if you have Navisworks 
installed on the same machine.  

 Navisworks also provides support for .dwg files enabling native CADWorx models to be read 
directly into Navisworks.  

 CADWorx object properties are also supported by Navisworks and these can be viewed in the 
'Properties' window. To open the Properties window, go to View tab > Workspace panel > 
Windows drop-down > Properties.  

 CADWorx piping, steel, and equipment data is fully supported by Navisworks.  
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  Exporter 
Native 
Format 

Other 
Format 

Properties 

 

CADWorx Pipe     

CADWorx Pipe Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from CADWorx as either .nwc or .nwd format, if you have Navisworks 
installed on the same machine. 

 Navisworks also provides support for .dwg files enabling native CADWorx models to be read 
directly into Navisworks.  

 CADWorx object properties are also supported by Navisworks and these can be viewed in the 
'Properties' window. To open the Properties window, go to View tab > Workspace panel > 
Windows drop-down > Properties.  

 The legacy product, CADWorx Pipe, is fully supported by Navisworks.  

 

CADWorx Steel     

CADWorx Steel Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from CADWorx as either .nwc or .nwd format, if you have Navisworks 
installed on the same machine. 

 Navisworks also provides support for .dwg files enabling native CADWorx models to be read 
directly into Navisworks.  

 CADWorx object properties are also supported by Navisworks and these can be viewed in the 
'Properties' window. To open the Properties window, go to View tab > Workspace panel > 
Windows drop-down > Properties. 

 CADWorx Steel is fully supported by Navisworks. 
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COINS  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

BSLink 
    

BSLink Details  

Other Formats DWG, DXF, 3DS 

 In order to read a BSLink file into Navisworks, you either need BSLink installed on the same 
machine as Navisworks, or AutoCAD installed complete with the BSLink object enabler.  

 If BSLink is installed, the object enabler is not necessary. With Navisworks installed on the same 
machine, simply export to .nwc or .nwd.  

 In Navisworks, object properties can be viewed in the 'BSLink' tab in the 'Properties' window. 
To open the properties window, go to View tab > Workspace panel > Windows drop-
down > Properties.  

Framing 
    

Framing Details  

Other Formats DWG, DXF, 3DS 

 In order to read a Framing file into Navisworks, you either need COINS Framing installed on the 
same machine as Navisworks, or ADT installed complete with the Framing object enabler.  

 If COINS Framing is installed, the object enabler is not necessary. If Navisworks is installed on 
the same machine, simply export to .nwc or .nwd.  

 In Navisworks, object properties can be viewed in the Framing tab in the Properties window. To 
open the properties window, go to View tab > Workspace panel > Windows drop-down > 
Properties.  

CSC  

3D+ 
  

 
 

3D+ Details  

Other Formats DWG, CIS/2 

 3D+ has a Navisworks Exporter, enabling you to export a Navisworks file out of 3D+.  
 Also see the 3D+ website for information on their 3D+ Navisworks Reader. This is a plug-in to 

Navisworks, enabling you to read the native .3nwc file format in Navisworks.  
 3D+ object properties are supported by Navisworks via either of the above routes.  
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Dassault Systemes  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

CATIA    
 

 

CATIA Details  

Other Formats DXF, IGES, STEP, JT 

 Navisworks has file readers for .dxf, .igs, .stp and .jt files, all of which can be exported from 
CATIA.  

 STEP is the preferred exchange format. 

Google  

SketchUp (up to 2016)  
  

 

SketchUp Details  

Other Formats DWG, 3DS 

 SketchUp .skp files (v5 up to 2016 can be read directly into Navisworks.  
 Grouping objects in SketchUp will make it easier to use the model in Navisworks, for example 

applying materials, or attaching objects to TimeLiner tasks.  

Hannappel SOFTWARE GmbH  

elcoCAD R4 
    

elcoCAD R4 Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from elcoCAD as either .nwc or .nwd format.  
 Navisworks also supports the native elcoCAD .dwg file format, which can be read directly into 

Navisworks.  
 Object properties are also supported by Navisworks and these can be viewed in the 'Properties' 

window. To open the Properties window, go to View tab > Workspace panel > Windows 
drop-down > Properties.  
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Intergraph  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

PDS 
    

PDS Details  

Other Formats DWG, DXF, DGN, IGES, STEP 

 Intergraph PDS will save the model geometry in a .dgn file and the property information in a 
.drv file. Both files are required by Navisworks to read the model with object properties.  

 In Navisworks, go to Tools > Global Options > DGN, scroll down and check the 'Convert PDS 
Data' option. Ensure the .dgn and .drv files reside in the same directory. Navisworks will then 
import the model, along with its properties.  

 PDS object properties can be viewed in the 'Properties' window. To open the Properties 
window, go to View tab > Workspace panel > Windows drop-down > Properties.  

 If Navisworks has been installed onto the same machine as Intergraph PDS, you will be able to 
export from PDS as a Navisworks .nwc or .nwd file. 

Informatix  

MicroGDS  
 

  

MicroGDS Details  

Other Formats MAN 

 Navisworks supports the native MicroGDS .man file format, which can be read directly into 
Navisworks.  

 Colors and Materials from the file are supported. The .man File Reader options can be found in 
Tools > Global Options > File Readers > MAN.  
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ITandFactory  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

 

CADISON     

CADISON Details  

Other Formats DXF, 3DS 

 Navisworks can directly read CADISON .dwg files, utilizing the .dwg file reader.  
 In order to read a CADISON file into Navisworks, you either need CADISON installed on the 

same machine as Navisworks, or you will need to install the CADISON Object Enabler.  
 If CADISON is installed, the object enabler is not necessary.  

 

 With either CADISON or the Object Enabler installed, simply open the CADISON .dwg file in 
Navisworks.  

 If CADISON is installed on the same machine as Navisworks, then you can also export to .nwc 
or .nwd.  

 Exporting a Navisworks file from CADISON also retains the models object properties that can be 
viewed in the 'Properties' window. To open the Properties window, go to View tab > 
Workspace panel > Windows drop-down > Properties.  

     

TRICAD MS 
 

 
  

TRICAD Details  

Other Formats VRML 

 If TriCAD MS is installed on the same machine as Navisworks, then you can also export to .nwc 
or .nwd.  

 Exporting a Navisworks file from TRICAD MS also retains the models object properties that can 
be viewed in the 'Properties' window. To open the Properties window, go to View tab > 
Workspace panel > Windows drop-down > Properties.  
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Kubotek USA  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

CADKEY     
 

  

CADKEY Details  

Other Formats DWG, DXF, IGES, STEP 

 Navisworks has file readers for .dwg files and also .dxf, .igs and .stp files, all of which are 
supported by CADKEY. 

M.A.P.  

CAD-Duct 
    

CAD-Duct Details  

Other Formats DWG, DXF, 3DS 

 In order to read a CAD-Duct file into Navisworks, you either need CAD-Duct installed on the 
same machine as Navisworks, or have the CAD-Duct Object Enabler installed. The CAD-Duct 
Object Enabler can be downloaded from the CAD-Duct website, found under Support > 
Additional Files.  

 If CAD-Duct is installed, the Object Enabler is not necessary. Simply export to .nwd or .nwc.  
 In Navisworks, object properties can be viewed in the 'CAD-Duct' tab in the 'Properties' 

window. To open the Properties window, go to View tab > Workspace panel > Windows 
drop-down > Properties.  
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McNeel North America  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

Rhino     
 

  

Rhino Details  

Other Formats DWG, DXF, 3DS, IGES, STEP 

 In Navisworks, you can now read native Rhino files directly. 

Mensch und Maschine  

RoCAD 
    

RoCAD Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from RoCAD as either .nwc or .nwd.  
 Navisworks also supports the .dwg file format, which can be read directly into Navisworks.  
 If you do not have RoCAD installed on the same machine as Navisworks, you will need to have 

AutoCAD installed, along with the RoCAD Object Enabler.  
 Object properties, (such as Material Colors and Entity Handles) are also supported by 

Navisworks and these can be viewed in the 'Properties' window. To open the Properties 
window, go to View tab > Workspace panel > Windows drop-down > Properties.  

MultiSUITE  

MultiSTEEL 
  

 
 

MultiSTEEL Details  

Other Formats DWG, DXF, 3DS 

 .dwg files from MultiSTEEL can be read directly into Navisworks utilizing the .dwg file reader.  
 Models can also be exported from MultiSTEEL as either .nwc or .nwd.  
 MultiSTEEL object properties can be viewed in the 'Properties' window. To open the Properties 

window, go to View tab > Workspace panel > Windows drop-down > Properties.  
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Nemetschek  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

Allplan   
 

 

Allplan Details  

Other Formats DWG, DXF, DGN, IFC 

 Allplan files can be viewed in Navisworks if they have been saved in one of the above formats.  
 Object properties are not supported.  

PROCAD  

3DSMART 
  

  

3DSMART Details  

Other Formats DWG, DXF, 3DS 

 With 3DSMART installed on the same machine as Navisworks, you can read your DWG file 
directly into Navisworks, utilizing the DWG file reader.  

 You can also export a .nwc file directly from 3DSMART. 

PTC  

Pro/ENGINEER  
  

 

Pro/ENGINEER Details  

Other Formats IGES, STEP, VRML, JT 

 Native Pro/ENGINEER format support; .PRT .ASM .G .NEU 
 Pro/ENGINEER models can be exported to any of the above file formats which can then be read 

into Navisworks.  

CADDS 5   
 

 

CADDS 5 Details  

Other Formats IGES, STEP 

 You can read CADDS 5 3D models into Navisworks, by exporting either an IGES or STEP file 
from CADDS 5 and then utilize either the Navisworks .igs, or .stp file readers.  
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QuickPen  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

PipeDesigner 3D 
    

PipeDesigner 3D Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from PipeDesigner 3D as either .nwc or .nwd format.  
 Navisworks also supports the native .dwg file format, which can be read directly into 

Navisworks if the relevant Object Enabler is installed. 
 Object properties, (such as Material Colors and Entity Handles) are also supported by 

Navisworks and these can be viewed in the 'Properties' window. To open the Properties 
window, go to View tab > Workspace panel > Windows drop-down > Properties.  

DuctDesigner 3D 
    

DuctDesigner 3D Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from DuctDesigner 3D as either .nwc or .nwd format.  
 Navisworks also supports the native .dwg file format, which can be read directly into 

Navisworks if the relevant Object Enabler is installed. 
 Object properties, (such as Material Colors and Entity Handles) are also supported by 

Navisworks and these can be viewed in the 'Properties' window. To open the Properties 
window, go to View tab > Workspace panel > Windows drop-down > Properties.  

RAM International  

CADstudio 
    

CADstudio Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from CADstudio as either .nwc or .nwd format.  
 Navisworks also supports the native CADstudio .dwg file format, which can be read directly into 

Navisworks.  
 Object properties are also supported by Navisworks and these can be viewed in the 'Properties' 

window. To open the Properties window, go to View tab > Workspace panel > Windows 
drop-down > Properties. 
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SolidWorks  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

SolidWorks  
  

 

SolidWorks Details  

Other Formats DWG, DXF, IGES, STEP, VRML, JT 

 Native SolidWorks format support; .PRT .SLDPRT .ASM .SLDASM 
 SolidWorks models can be exported to DWG, DXF, IGES, STEP, VRML or JT format which can 

then be read into Navisworks.  

Tekla  

Tekla Structures   
  

Tekla Structures Details  

Other Formats DGN, VRML, CIS/2 

 Tekla Structures can export to the .dgn file format, which can be read directly into Navisworks.  
 Tekla Structures can additionally output to CIS/2. This may then be converted to VRML using 

the translator from the National Institute of Standards and Technology (see the NIST website for 
more information). The VRML file can then be read directly into Navisworks.  

 Limited object properties are supported via the .dgn route.  

Xsteel   
  

Xsteel Details  

Other Formats DGN 

 Xsteel can export to the .dgn file format, which can be read directly into Navisworks.  
 Limited object properties are supported via the .dgn route.  

think3  

thinkdesign   
 

 

thinkdesign Details  

Other Formats DWG, DXF, IGES, STEP 

 Navisworks has file readers for .dwg/.dxf files and also .igs and .stp files.  
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UGS  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

I-deas   
 

 

I-deas Details  

Other Formats DXF, IGES, STEP, JT 

 Navisworks has file readers for .dxf, .igs .stp and .jt files.  

Solid Edge   
 

 

Solid Edge Details  

Other Formats IGES, STEP, JT 

 Solid Edge can export to IGES STEP and JT files, which can be read directly into Navisworks.  

NX (Unigraphics)  
  

 

NX Details  

Other Formats DXF, IGES, STEP, JT 

 Native NX format support; .PRT. 
 Navisworks has file readers for .dxf, .igs .stp and .jt files.  

FactoryCAD 
   

 

FactoryCAD Details  

Other Formats DWG, DXF, 3DS 

 In order to read a FactoryCAD file into Navisworks, you either need FactoryCAD or the 
FactoryCAD object enabler installed on the same machine.  

 If FactoryCAD is installed, the object enabler is not necessary. Simply export to .nwc or .nwd. 
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UHP Process Piping  

  Exporter 
Native 
Format 

Other 
Format 

Properties 

FabPro Pipe 
   

 

FabPro-Pipe Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from FabPro Pipe as either .nwc or .nwd format.  
 Navisworks also supports the native FabPro Pipe .dwg file format, which can be read directly 

into Navisworks.  

x-plant  

x-plant 
   

 

x-plant Details  

Other Formats DWG, DXF, 3DS 

 Models can be exported from x-plant as .nwc format. 
 Navisworks also supports the native x-plant .dwg file format, which can be read directly into 

Navisworks. 
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